Blog

OAuth Reauthentication

Posted by Chika on 6/29/2011 04:45:00 PM

To comply with Twitter's new OAuth requirement, all of the Echofon applications will ask users to re-authenticate their accounts.

This is Twitter's new security measure for all third party applications, and you have to re-authenticate to read or delete DMs via Echofon after July 1st, 2011.

Re-authenticating is easy - Update your Echofon to the latest version (see below), you will be prompted to do so when needed.

  • Echofon iPhone version 4.0.9
  • Echofon Firefox version 2.0.9
  • Echofon Mac version 1.4.7

To learn more about Twitter's requirements and OAuth, please visit Twitter's blog post.

UPDATE 12:00PM 6/30/2011: The new permission level is now in effect. There are few minor issues regarding re-authenticating. If you get into re-authentication loop, here's some workaround:

Firefox: Please update to version 2.0.9, or re-start Firefox after you re-authorized Echofon.

iPhone/iPad/Mac: Deleting account then re-adding it will solve the issue.